• Welcome to Christian Photographers Community. Please login or sign up.
 
May 13, 2021, 04:49:07 PM

News:

Check out our new challenge

BIRDS,BEES,FLOWERS,TREES
HERE


Random Image

Glorious and Majestic are His deeds!

Owner: rocky0728

Mini Challenge Winners

Help us Congratulate the Winner of Mini Challenge #106~My Favorite Things
Here
Congratulations Fotobirder!
Bird Photos In Snow

Today's Verse

Shoutbox

JudyB: I've gone crazy posting songs today, all but one were Pat's favourites too! Apr 15 2021 10:24pm

JudyB: Good Morning everyone!  October's devotional has started! Oct 01 2020 10:25am

JudyB: July 2020 has been started!! Jul 01 2020 12:57pm

Carol: This is the only place I can reply. I read all your notes - take care.  Jun 27 2020 9:12am

JudyB: Good day everyone, Have a wonderful day! Jun 23 2020 12:25pm

JudyB: Hey Everyone June has been posted!  Please don't post in May Jun 01 2020 1:32am

Carol:  :)  Thankful for all the beautiful music.  I hope you get this message because I cannot get to the normal reply.  May 01 2020 11:48am

JudyB: The new month has been posted!!! May 01 2020 11:27am

JudyB: Hey everyone a new month has started.  Apr 04 2020 10:10am

Carol: Knock knock....Carol   Help me get in here, please. Mar 17 2020 6:33pm

Gallery Problems

Started by Oldiesmann, November 21, 2011, 02:24:03 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Oldiesmann

We're having some minor technical issues with the gallery at the moment, so if you run into an issue, please post here and let me know what the problem is.

The main issue at the moment seems to be that the user album IDs got all messed up in the forum's members table. If you click on a user's camera icon and get a "security violation" message, let me know whose album you were trying to view when you got that message. I have already fixed the album IDs for several users, but I'm sure more issues will pop up.

If you get any other errors while trying to view the gallery, post here saying what message you got and what you were doing at the time.

I'm not sure what caused things to get so screwed up, but am working to fix them as I find them.

On a more positive note, I went ahead and updated the gallery integration addon here, so you will notice a few minor changes:
You can now access your user album and gallery profile directly from the Gallery menu (admins can access the integration settings and gallery admin center from this menu as well)
The "View <user>'s gallery album" link in the profile has been replaced with the same camera icon seen in posts
The "View <user>'s Gallery profile" link in the forum profile has been moved to the Profile Info menu.
The Oldiesmann
Forum Guru
I've sinned greatly, but Christ's for real, baby, it's a wonder He saved me and just didn't hate me, so won't you tell Him 'Save me!' and please stand up?... - J. Jackson (http://www.apologetix.com for more info).

BigSkyKen

I just tried to click on the camera icon below your's, Pat's and Betty's avatars, and got the security violation message on all three.  If I click on my own, I am able to access my gallery.
Big Sky Ken
"Therefore, to one who knows the right thing to do and does not do it, to him it is sin."  James 4:17

Oldiesmann

That's odd, as I fixed the IDs for me and Pat (I think Betty's was already working), and they were all working as of last night.

What URL is it sending you to for those three? It should be christianphotographers.com/community/v/<username>;
The Oldiesmann
Forum Guru
I've sinned greatly, but Christ's for real, baby, it's a wonder He saved me and just didn't hate me, so won't you tell Him 'Save me!' and please stand up?... - J. Jackson (http://www.apologetix.com for more info).

BigSkyKen

Big Sky Ken
"Therefore, to one who knows the right thing to do and does not do it, to him it is sin."  James 4:17

Oldiesmann

Quote from: BigSkyKen on November 21, 2011, 02:19:18 PM
Here is the url for your's:  http://www.christianphotographers.com/community/v/Oldiesmann/

That's the correct URL. Not sure why it'd be giving you a security violation.
The Oldiesmann
Forum Guru
I've sinned greatly, but Christ's for real, baby, it's a wonder He saved me and just didn't hate me, so won't you tell Him 'Save me!' and please stand up?... - J. Jackson (http://www.apologetix.com for more info).

Betty

Hi,
I've never been able to get on to anyone's gallery. When I click on the Gallery link (in the Home, forum, etc. toolbar), I have always had it go to Security Violation. The action you attempted is not permitted. Back to the gallery. If you click on Back to the Gallery, it just comes up with the same page.
The URL when I'm trying to access the Gallery is: http://www.christianphotographers.com/community/index.php?action=gallery
Aren't computers fun?
Betty

Enjoying God's handiwork!

Papasmirf

First I can't log out I get "Session verification failed. Please try logging out and back in again, and then try again."

Earl
Earl Kauffman

RuthV

November 21, 2011, 09:51:43 PM #7 Last Edit: November 21, 2011, 09:59:49 PM by RuthV
Put me down as having the same problem..... I can get to my gallery because the pull down menu under "Gallery", along the menu bar gives me two choices; Your Album and Your Gallery Profile. I used to go to a site where all were displayed and then search for mine!  :)
Now I can't even click on the Random Image to see whose gallery it's in...
and you're correct, Papasmirf, I cannot log out...

Jeanne Lee

Hmmmm! I just tried to "log out" and ran into the same problem.  Since no one else ever has access to my computer I don't log out, just close down by the "x" in the corner, so this was a surprise to me.
Click for Corinth, New York Forecast" border="0" height="41" width="127

RuthV

Hi!
Check out Forum: "Well......I WAS going to post an update...." by CapturedByGrace..(Kelly).. she too is having problems! http://www.christianphotographers.com/community/index.php?topic=12031.msg168212;topicseen#new


Oldiesmann: Thank you for all your work on this site. My son also gets into solving computer techie problems and I know sometimes it takes HOURS. Knowing it's your part-time occupation; THANK YOU......!!! I know you will be successful with the help of C.P. keeping you in our prayers...

Oldiesmann

The logout issue has been fixed.

I'm still not sure why you're getting security violation errors with the gallery. I'm in class right now but will look into that further when I get home in a couple of hours.
The Oldiesmann
Forum Guru
I've sinned greatly, but Christ's for real, baby, it's a wonder He saved me and just didn't hate me, so won't you tell Him 'Save me!' and please stand up?... - J. Jackson (http://www.apologetix.com for more info).

Marilyn

Michael I just tried to go to your gallery and got this message
QuoteThe action you attempted is not permitted.
It is the same  when I click on other people's  gallery icon.
"Good people take care of their animals, but even the kindest acts of the wicked are cruel" Prov. 12:10
Click for North Bend, Oregon Forecast" border="0" height="100" width="150        My Website

JudyB

Marilyn it is in the precess.........Of being fixed.


Oldiesmann

Quote from: Marilyn on November 23, 2011, 02:16:32 PM
Michael I just tried to go to your gallery and got this message
QuoteThe action you attempted is not permitted.
It is the same  when I click on other people's  gallery icon.

Is that the only error you get? I'll look into it more after work tomorrow and see if I can figure out what's going on.
The Oldiesmann
Forum Guru
I've sinned greatly, but Christ's for real, baby, it's a wonder He saved me and just didn't hate me, so won't you tell Him 'Save me!' and please stand up?... - J. Jackson (http://www.apologetix.com for more info).

Oldiesmann

I found the error in the Gallery event log, but cannot for the life of me figure out what's going on here. I have verified that the IDs being passed are correct everywhere, and that permissions are correct. I honestly have no clue why it's giving you security errors :|

I will try to look into it in more detail later this week as I have time, but I don't know that I'll be able to get anywhere.

Does it work if you try accessing it from outside the forum? http://www.christianphotographers.com/community/gallery2
The Oldiesmann
Forum Guru
I've sinned greatly, but Christ's for real, baby, it's a wonder He saved me and just didn't hate me, so won't you tell Him 'Save me!' and please stand up?... - J. Jackson (http://www.apologetix.com for more info).

BigSkyKen

No, I get the same error when I try that link.
Big Sky Ken
"Therefore, to one who knows the right thing to do and does not do it, to him it is sin."  James 4:17

Oldiesmann

That's really weird. I've posted a topic about this issue on the Gallery support forums and will continue to look at my code as I have time to see if I can figure this out.
The Oldiesmann
Forum Guru
I've sinned greatly, but Christ's for real, baby, it's a wonder He saved me and just didn't hate me, so won't you tell Him 'Save me!' and please stand up?... - J. Jackson (http://www.apologetix.com for more info).

Oldiesmann

Can those who were having trouble accessing things try again and let me know if you can get in now?

I think I may have gotten to the bottom of this, but I'm not entirely sure (nor am I sure why this issue is just now coming up - not sure if it's a problem with my code or a problem with the way gallery handles things).

The error being generated is what happens when you try to view something you don't have permission to view. I'm wondering if the gallery doesn't consider you part of the "Everybody" group (a group that should apply to every person who views the gallery, registered or otherwise) if you're in another group. I was under the impression that the gallery allowed you to be part of multiple groups, but that may not be the case.

The integration here is set up to sync membergroups and group membership between the gallery and the forum. The "Everybody" group had permission to view things, but none of the other (forum-specific) groups did. I've gone through and added permissions for all of those groups (which are automatically applied to all sub-items [other albums and photos]), to see if that fixes the issue.

If it does fix the issue, I'll have to either tweak my code to handle copying permissions from the "everybody" and "registered users" groups when a new group is created in the gallery.
The Oldiesmann
Forum Guru
I've sinned greatly, but Christ's for real, baby, it's a wonder He saved me and just didn't hate me, so won't you tell Him 'Save me!' and please stand up?... - J. Jackson (http://www.apologetix.com for more info).

Betty

As far as I know, mine is working okay now. Since I really didn't have full access before, I'm not sure if everything is working - there may be areas I don't know to check.
However, I can now access galleries of people by clicking on the camera beneath their name! And when I click on Gallery, I can now see them. I've also been able to upload a picture to My Gallery.
Thank you! I know this can be a lot of work.
Betty

Enjoying God's handiwork!

JudyB

Oldiesman you are doing a wonderful job of figuring this out.  Thank you!


Oldiesmann

Glad it seems to be fixed now. I'll have to go do some more digging to figure out why it's happening in the first place, but at least everyone should be able to access the gallery now.
The Oldiesmann
Forum Guru
I've sinned greatly, but Christ's for real, baby, it's a wonder He saved me and just didn't hate me, so won't you tell Him 'Save me!' and please stand up?... - J. Jackson (http://www.apologetix.com for more info).

BigSkyKen

Thanks Michael, everything seems to be working correctly now.
Big Sky Ken
"Therefore, to one who knows the right thing to do and does not do it, to him it is sin."  James 4:17

RuthV


Papasmirf

I can click on the "gallery" and get the global photo gallery. However, when I click on the "your gallery" in the lower right side I get the same message "Security Violation. The action you attempted is not permitted." So I can't create a new gallery.

Thanks

Earl Kauffman
Earl Kauffman

Betty

I can't access papasmirf's gallery
Betty

Enjoying God's handiwork!

Pat

Michael, when I click on the camera icon for PapaSmirf, I get the following:



Error Detail -
Error (ERROR_MISSING_OBJECT) : Missing object for 301
in modules/core/classes/GalleryStorage/GalleryStorageExtras.class at line 2054 (GalleryCoreApi::error)
in modules/core/classes/GalleryStorage/GalleryStorageExtras.class at line 98 (GalleryStorageExtras::_identifyEntities)
in modules/core/classes/GalleryStorage.class at line 314 (GalleryStorageExtras::loadEntities)
in modules/core/classes/helpers/GalleryEntityHelper_simple.class at line 71 (GalleryStorage::loadEntities)
in modules/core/classes/GalleryCoreApi.class at line 2361 (GalleryEntityHelper_simple::loadEntitiesById)
in modules/core/classes/GalleryView.class at line 356 (GalleryCoreApi::loadEntitiesById)
in modules/core/ShowItem.inc at line 106 (GalleryView::getItem)
in modules/core/ShowItem.inc at line 61 (ShowItemView::getItem)
in modules/core/classes/GalleryView.class at line 293 (ShowItemView::loadTemplate)
in main.php at line 465 (GalleryView::doLoadTemplate)
in main.php at line 104
in modules/core/classes/GalleryEmbed.class at line 189
in /home/christia/public_html/community/Sources/Gallery.php at line 189 (GalleryEmbed::handleRequest)
in ??? at line 0
in /home/christia/public_html/community/index.php at line 152
System Information
Gallery version    2.3.1
PHP version    5.3.6 litespeed
Webserver    LiteSpeed
Database    mysql 5.1.56-log
Toolkits    Gd
Operating system    Linux titan.geekstorage.com 2.6.18-338.12.1.el5.lve0.8.34 #1 SMP Tue Jun 7 16:46:50 EEST 2011 x86_64
Browser    Mozilla/5.0 (Windows NT 5.1) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.121 Safari/535.2



"Click for Waterloo Wellington, Ontario Forecast"

JudyB

A lot of goblety gook.  Hope you can figure it out Michael!


mtekrony

I'm a newbie, so I may be missing something very simple, so forgive me.  I've been trying to create an album (my first) and when I click on gallery and then "your album" I get an error saying that I don't have permission to do this.

Can you help me please?

Thanks.

Jeanne Lee

Mketrony, this has begun to be a recurring problem for new members.  The webmaster, Oldiesmann (Michael) has been notified and it should soon be corrected.

Welcome to Christian Photographers, and best wishes for a blessed New Year.   :)
Click for Corinth, New York Forecast" border="0" height="41" width="127

Oldiesmann

I'm looking into the issues. Not sure what's going on this time, as all the groups have appropriate permissions as far as I can tell.
The Oldiesmann
Forum Guru
I've sinned greatly, but Christ's for real, baby, it's a wonder He saved me and just didn't hate me, so won't you tell Him 'Save me!' and please stand up?... - J. Jackson (http://www.apologetix.com for more info).

Oldiesmann

Fixed one issue... The ID for Papasmirf's album was wrong in the forum members table. I've fixed that, so everyone should be able to access it now without getting the "ERROR_MISSING_OBJECT" message (which means that the gallery couldn't find anything with that specific ID).

I'm still not sure why Papasmirf and mtekrony are/were unable to access their albums. I've checked and the ownership and permissions are set properly on both. Can you two try accessing them again (either by clicking on the "Your Album" link from the gallery or by clicking the camera icon in your posts/profiles)?
The Oldiesmann
Forum Guru
I've sinned greatly, but Christ's for real, baby, it's a wonder He saved me and just didn't hate me, so won't you tell Him 'Save me!' and please stand up?... - J. Jackson (http://www.apologetix.com for more info).

JudyB

Michael you are doing a wonderful job. Thank you and Happy New Year!


marloandlarry628

Thank you Michael for working on the Gallery I know it is hard keeping up with everyone!!!!
Be not forgetful to entertain strangers; for thereby some have entertained angels unawares. Hebrews 13:2

http://www.flickr.com/photos/youbejesustoday/

http://www.youbejesustoday.com